Some Slack events are delayed or missing

Incident Report for PullFlow

Postmortem

Slack events were getting reverified by API after being processed by queue. The queue was not sending verification header to API which was causing the verification exception in “isProduction” mode.

The queue endpoint change was only tested locally and the ‘isProduction’ path was not executed.

Lesson: Always test on preflight since it emulates isProduction

Posted Apr 09, 2025 - 17:46 UTC

Resolved

We have deployed a fix and confirmed that the issue is now resolved. Slack events should work as expected going forward.
Posted Apr 09, 2025 - 17:43 UTC

Identified

The recent Slack app update caused a degradation of Slack events in PullFlow. We have identified the issue and are currently working on a fix. We will update the incident as soon as we have more information.
Posted Apr 09, 2025 - 16:57 UTC
This incident affected: PullFlow Platform.