Slack Connectivity Issue Affecting PullFlow Integrations

Incident Report for PullFlow

Resolved

This incident has been resolved.
Posted May 13, 2025 - 00:23 UTC

Investigating

Slack is currently experiencing a connectivity incident, which is impacting PullFlow’s Slack-based integrations. We are actively monitoring the situation and will provide updates as soon as service is restored.
Posted May 12, 2025 - 22:58 UTC
This incident affected: PullFlow Platform and Slack Apps/Integrations/APIs.